Archive for the ‘CMS’ Category

Alliberat WordPress 3.1.3

divendres, maig 27th, 2011

Abans d’ahir s’alliberà la versió 3.1.3 de WordPress.

Bàsicament són actualitzacions de seguretat. Solució de bugs, i introducció de mesures més estrictes de seguretat.

Anunci oficial: http://wordpress.org/news/2011/05/wordpress-3-1-3/

Alliberat WordPress 3.1.2 (seguretat)

dimecres, abril 27th, 2011

S’ha publicat una actualització de seguretat per a WordPress.

El bug que soluciona era que un usuari de nivell contribuïdor podia publicar comentaris sense autorització.

Veure notícia a WordPress.

Alliberat WordPress 3.1.1

divendres, abril 8th, 2011

El proppassat dia 5 d’Abril s’alliberà la versió 3.1.1 de WordPress.

Bàsicament és una actualització de seguretat, pel que es recomana tothom d’actualitzar-se.

 

Alliberat VirtueMart 1.1.8 (Seguretat)

dissabte, març 26th, 2011

VirtueMart és un programari lliure per a Joomla que converteix el web en un lloc de comerç electrònic (E-Commerce).

S’ha alliberat la versió 1.1.8 degut al descobriment d’un problema de seguretat, per tant es recomana actualitzar tan aviat com sigui possible.

Es pot actualitzar des d’aquí:

http://virtuemart.net/downloads

Adreça curta Twitter: http://wp.me/pzeab-1NS

Alliberat WordPress 3.0.5

Dimarts, febrer 8th, 2011

Ahir s’alliberà la versió 3.0.5 de WordPress que bàsicament soluciona uns problemes de seguretat.

Es recomana a tothom actualitzar.

Problemes amb les etiquetes i categories

dissabte, gener 1st, 2011

Acabo de descobrir que al bloc s’han reiniciat totes les etiquetes i categories.

Això vol dir que tots els articles han perdut la seva categoria, tot apareix publicat a general, i les seves etiquetes.

Per aquest motiu no apareixen articles relacionats, no funcionen les categories, i si véns de google per categories o etiquetes no trobaràs, cosa que ja ha penalitzat el webranking.

Crec que té a veure amb un bug de la darrera versió de WordPress, la 3.0.4. Estic investigant si només afecta a la versió en Català, no ho crec, o a totes.

Estic reportant-ho a WordPress.

Actualització: Després de revisar el sistema, s’havia quedat pràcticament sense espai en disc. En alliberar espai, la situació s’ha recuperat sola i les Categories i Etiquetes han tornat. Com la incidència ha durat mitja hora, la baixada de visites es deu a la temporada de l’any.

Alliberat WordPress 3.0.4

dijous, desembre 30th, 2010

Fa unes hores s’ha alliberat la versió 3.0.4 de WordPress.

És molt important actualitzar a aquesta versió ja que soluciona un bug de seguretat catalogat com crític.

Veure anunci oficial.

Alliberat WordPress 3.0.3

dijous, desembre 9th, 2010

Fa unes hores s’ha alliberat WordPress 3.0.3.

Aquesta versió bàsicament soluciona uns problemes de seguretat que podrien permetre a contribuïdors i autors a editar, eliminar i publicar articles sense tenir-ne permisos.

Aquests problemes de seguretat, nogensmenys, tan sols afecten els llocs que tenen activada la publicació remota.

Podeu veure notes de la versió aquí: http://wordpress.org/news/2010/12/wordpress-3-0-3/

Alliberat WordPress 3.0.2

dijous, desembre 2nd, 2010

Ahir s’alliberà la darrera versió de WordPress 3.0.2.

Es recomana tothom que actualitzi la seva instal·lació puix que soluciona problemes de seguretat importants.

Alliberat WordPress 3.0.1

divendres, juliol 30th, 2010

Ahir dia 29 es va alliberar WordPress 3.0.1.

42 dies després de la publicació de la versió 3.0 alliberen aquesta actualització que soluciona una cinquantena de bugs de poca criticitat.

Podeu veure l’anunci oficial al seu blog:

http://wordpress.org/news/2010/07/wordpress-3-0-1/

També us pot interessar saber que a la propera versió 3.2, programada per a ser alliberada la primera meitat de 2011, no se suportarà cap versió de PHP inferior a la 5.2 ni de MySql inferior a la 5.0.15.

Aquí podeu veure la l’anunci oficial:

http://wordpress.org/news/2010/07/eol-for-php4-and-mysql4/

Alliberat Drupal 6.16

dissabte, març 6th, 2010

El proppassat dia 4 fou alliberat Drupal 6.16.

Drupal és un programari lliure, gestor de continguts (Content Management System).

Aquesta nova versió soluciona molts errors, però sobretot evita uns forats de seguretats força greus descoberts darrerament.

Veure: Anunci oficial de Drupal

Alliberat WordPress 2.9.2 (seguretat)

Dimarts, febrer 16th, 2010

WordPress ha alliberat la versió 2.9.2, bàsicament soluciona un problema de seguretat en que els usuaris registrats, sense permisos d’administració, podien accedir als articles esborrats, a la paperera.

Darrerament s’havien registrat més usuaris que de costum al bloc, i ara comprenc perquè.

Via: WordPress bloc oficial

WordPress: Crear una pàgina per a cada usuari registrat

dilluns, gener 25th, 2010

WordPress suporta mostrar pàgines per als usuaris registrats.

L’enfocament és pensat per a autors d’articles, però pot mostrar informació de qualsevol usuari registrat encara que no hagi publicat cap article, ni tingui permisos per a fer-ho.

Nogensmenys la majoria de temes de WordPress no porten la pàgina author.php

Quan això passa si es demana la url d’un autor, per exemple:

http://www.codic.cat/author/carles/

WordPress empra la pàgina del tema archive.php

Però podem fer que WordPress mostri una plana personalitzada per als nostres usuaris desant una plana nova que es digui author.php al directori del nostre tema.

Podem per exemple fer una còpia d’archive.php i anomenar-la author.php i llavors personalitzar-la.

Haurem d’afegir un codi a la part superior, sota de:

get_header();

de manera que quedarà quelcom així:

<?php
/*
*
* @package WordPress
* @subpackage Default_Theme
*/

/*
    Arxiu AUTHOR.PHP creat el 2010/01/24 per Codic.cat
    Permet de tenir plana d'usuaris.
*/

get_header();

// **************************************************
//  Aquí comença el codi per a Author.php
// **************************************************
// Codi de http://codex.wordpress.org/Author_Templates

if(isset($_GET['author_name'])) :    // NOTE: 2.0 bug requires: get_userdatabylogin(get_the_author_login());
    $curauth = get_userdatabylogin($author_name);
else :
    $curauth = get_userdata(intval($author));
endif;
?>

<div id="content">
<h2>Perfil de l'usuari <?php  echo $curauth->nickname; ?></h2><BR>
<?php
// **************************************************
//  Aquí acaba el codi per a Author.php
// **************************************************

<?php
if (have_posts()) {

Amb la funció get_userdata($user) podem accedir a força informació:

<?php
     $user_info = get_userdata(1);
     echo("Nom de l'usuari: ".$user_info->user_login."<br/>");
     echo("Nivell de l'usuari: ".$user_info->user_level."<br/>");
     echo("ID de l'usuari: ".$user_info->ID."<br/>");
     echo("Nom i cognom: ".$user_info->first_name.", ".$user_info->last_name."<br/>");
?>

Podem accedir a aquestes dades:

Taula: user
ID
user_login
user_pass
user_nicename
user_email
user_url
user_registered
user_activation_key
user_status
display_name

Taula: user_meta
first_name
last_name
nickname
description
user_level
admin_color (Tema de la vostra plana d'administrador.Per defecte és fresh.)
closedpostboxes_page
nickname
primary_blog
rich_editing
source_domain

Segons la documentació a partir de la versió 2.0 a més podem emprar:
aim
jabber
yim

I a la versió 1.2 i 1.5:
user_msn
user_icq

Podeu trobar més informació a:

http://codex.wordpress.org/Function_Reference/get_userdata

http://codex.wordpress.org/Function_Reference/get_currentuserinfo

http://codex.wordpress.org/Author_Templates

http://codex.wordpress.org/Template_Hierarchy

Alliberat WordPress 2.9.1

Dimarts, gener 5th, 2010

Fa unes hores s’ha alliberat WordPress 2.9.1.

Aquesta nova versió soluciona els problemes de la versió 2.9 indicats en el darrer article i d’altres com ara que no es veien alguns enllaços.

Jo havia detectat errors en els que duien accents i altres signes dels quals no disposen en anglès.

Un dels errors impedia d’actualitzar a la versió 2.9, “Upgrades Fail Because of [11883]“, ja està solucionat.

Veure: Nota oficial de WordPress.

Veure: Tots els errors esmenats a la versió 2.9.1.

Bugs a WordPress 2.9

dimecres, desembre 23rd, 2009

S’han detectat uns problemes a la darrera versió de WordPress 2.9 i estan treballant en la versió 2.9.1 que els solucionarà.

Els problemes es basen en un error, en algunes versions de PHP, amb curl que afecta bàsicament a articles marcats al calendari per a que es publiquin més tard, els pingbacks i alguns errors menors més.

Fins ara 40 tiquets (es denomina tiquet a una incidència enregistrada al sistema de solució d’errors) han estat solucionats.

Hi ha una versió 2.9.1 BETA 1, per si algú no vol esperar aquests dies, i vol ajudar en el testeig. Per a fer-ho cal instal·lar el plugin Beta Tester.

Veure anunci al bloc oficial de WordPress.