Solució de problemes amb WAMP i PHP 5.3.x

Si treballeu amb WAMP Wampserver 2.oi amb el mòdul de PHP 5.2.11,  us podeu haver trobat amb un error que fa que qualsevol versió de PHP 5.3.x falli.

En alguns webs he trobat que això es deu a que manca una llibreria (DLL), nogensmenys wampserver base amb PHP 5.3.0 sense el 5.2.11 funciona perfectament jo ho he pogut solucionar instal·lant el paquet original de PHP, el darrer a data de 24 d’Abril de 2010, PHP 5.3.2.

En el meu cas l’he instal·lat a C:\PHP mentre que els de WAMP són a c:\wamp\bin\php\ per exemple C:\wamp\bin\php\php5.3.0.

Ara bé, quan inicieu Wamp haureu de tenir cura ja que el PHP.INI que carregarà serà el de C:\PHP.

Això ho podeu revisar amb un phpinfo, si no sabeu què és, es tracta d’una funció que envia al navegador tota la informació de configuració de PHP:

<?php

// Mostra tota la informació, INFO_ALL
phpinfo();

// Si només volguéssim dels mòduls, INFO_MODULES
// phpinfo(8) és el mateix.
phpinfo(INFO_MODULES);

?>

Català-Catalunya English-USA Traduir a l'Anglès. Translate to English Compartir: La TafaneraIndependènciaCatosfera|FacebookTwitterFriend Feed|googleDeliciousDiggTechnoratiredditmixxyahoolivestumbleuponsimpy

Tags: ,

1.650 visualitzacions - versió en PDF

Comments are closed.